Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
brak połączenia z postgresql z sieci
27-12-2010, 03:14 PM
Post: #1
brak połączenia z postgresql z sieci
Witam wszystkich,
mam następujący problem:
dwa komputery:
- UBUNTU 10.04, Posgresql 8.4, PostGIS, Quantum 1.6
--> baza i wszystko chodzi na localhoście wyśmienicie, ip lokalne 192.168.0.103, 255.255.255.0
- OpenSuse 11.3, Quantum 1.6 , ip lokalne 192.168.0.100
--> brak możliwości połączenia z bazą na ubuntu, wyrzuca : "serwer doesn't listen, sprawdź czy serwer działa na ip 192.168.0.103 i czy zapory pozwalają na ruch na porcie 5432...."

Próbowałem już wszystkiego kilkukrotnie z podobnych wpisów na forum i w manualach...
stosowałem różne ustawienia i uprawnienia...

oto moje pliki konfiguracyjne:

posgreesql.conf:
listen_addresses = '*'

pg_hba.conf:
host all all 192.168.0.100/32 md5
host all all 127.0.0.1/32 md5

Będę zobowiązany za wskazówkę, gdzie tkwi błąd.
Może powinienem szukać jeszcze gdzieś.
Zapory sieciowe w obu komputerach są WYŁĄCZONE, więc wszystko przelatuje przez sieć ..
Dziękuję.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
27-12-2010, 05:41 PM
Post: #2
RE: brak połączenia z postgresql z sieci
(27-12-2010 03:14 PM)tomsik napisał(a):  host all all 192.168.0.100/32 md5
host all all 127.0.0.1/32 md5

Wynikiem maski 32 jest tylko adres wejściowy. http://www.postgresql.org/docs/8.4/stati...-conf.html.

@Admini: Ten temat powinien chyba zostać przeniesiony do Linux dla początkujących.

Maciej Sieczka
http://www.sieczka.org
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
27-12-2010, 06:34 PM
Post: #3
RE: brak połączenia z postgresql z sieci
(27-12-2010 05:41 PM)msieczka napisał(a):  Wynikiem maski 32 jest tylko adres wejściowy. http://www.postgresql.org/docs/8.4/stati...-conf.html.

zgadza się, po zmianie maski na :

host all all 192.168.0.0/16 md5

co skutkuje ustawieniem szerszej puli wejściowych adresów IP
nic się nie zmienia, dlaej ten sam błąd.
Będę próbował jeszcze z widowsa .. napiszę co wyszło...

Z góry dziękuję i czekam dalej ... Wink
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
27-12-2010, 08:50 PM
Post: #4
RE: brak połączenia z postgresql z sieci
[/quote]
host all all 192.168.0.0/16 md5
nic się nie zmienia, dlaej ten sam błąd.
[/quote]

Restart serwera Postgres zrobiłeś? Co masz w /etc/hosts.deny i /etc/hosts.allow? Co mówi "iptables -L" na serwerze? Na pewno masz serwer na ipku 192.168.0.103 i z nim próbuejsz się lączyć z klienta? Co mówi "ifconfig" na serwerze?

Maciej Sieczka
http://www.sieczka.org
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
27-12-2010, 10:49 PM
Post: #5
RE: brak połączenia z postgresql z sieci
Restart serwera Postgres zrobiłeś? -- kilkadziesiąt razy,

Co masz w /etc/hosts.deny i /etc/hosts.allow? -- obydwa pliki w całości wyhaszowane

Co mówi "iptables -L" na serwerze?
Chain ufw-user-input (1 references)
target prot opt source destination
ACCEPT tcp -- 192.168.0.0 192.168.0.255 tcp spt:postgresql dpt:postgresql


Na pewno masz serwer na ipku 192.168.0.103 i z nim próbuejsz się lączyć z klienta? Co mówi "ifconfig" na serwerze?
--na pewno jest na tym ip: oto fragment :
root@tomek-ubuntu:/home/tomek# ifconfig
eth0 Link encap:Ethernet HWaddr 90:e6:ba:1e:79:18
inet addr:192.168.0.103 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::92e6:baff:fe1e:7918/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:151335 errors:0 dropped:0 overruns:0 frame:0
TX packets:133696 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:91726141 (91.7 MB) TX bytes:13961937 (13.9 MB)
Interrupt:35 Base address:0xe000


Taka rzecz mi się nasuwa ... czy musi być włączone ssh na serwerze? bo tylko tego jeszcze nie testowałem.
Dziękuję i proszę o jeszcze. Blush
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
27-12-2010, 11:08 PM
Post: #6
RE: brak połączenia z postgresql z sieci
To jeszcze może:
* czy ta linia z listen_addresses = '*' jest aby na pewno odkomentowana? Wink
* może masz pliki .conf w dwóch miejscach i zmieniasz w jednym, a Postgres bierze z drugiego? (miałem taki przypadek na Debianie: raz w etc, drugi - var/lib)
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
27-12-2010, 11:30 PM (Ten post był ostatnio modyfikowany: 31-12-2010 01:19 PM przez tomsik.)
Post: #7
RE: brak połączenia z postgresql z sieci
SOLVED ! Big Grin
na rozwiązanie natknąłem się przypadkiem, jeśli ktoś będzie miał podobny problem to może się przyda.
Powodem zamieszania była zapora, bo nawet jak była wyłączona - to przez porty ruch był chyba zablokowany. Dopiero uaktywnienie zapory i wpisanie tej linijki spowodowało rozwiązanie problemu. Poniżej moje ustawienia plików konfiguracujnych. Konfiguracja: system UBUNTU 10.04, baza POSTGRESQL 8.4, sieć lokalna 192.168.0.xxx

ustawienie pliku postgresql.conf :
listen_addresses = '*'

ustawienie pliku pg_hba.conf:
# IPv4 local connections:
host all all 192.168.0.0/24 md5
host all all 127.0.0.1/32 md5


ustawienie zapory:
to 192.168.0.0 5432/tcp ALLOW IN from 192.168.0.0 5432/tcp

dziękuję i pozdrawiam.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Skocz do: