Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
niepoprawne sortowanie w tabeli atrybutów
12-12-2016, 03:23 PM (Ten post był ostatnio modyfikowany: 12-12-2016 03:26 PM przez Mazur.)
Post: #1
niepoprawne sortowanie w tabeli atrybutów
Dlaczego przy obszernych plikach Qgis nie sortuje wielkości liczbowych w poprawny sposób (malejąco - rosnąco) przy kliknięciu w nagłówek kolumny ?
I jak to obejść ?

(12-12-2016 03:23 PM)Mazur napisał(a):  Dlaczego przy obszernych plikach Qgis nie sortuje wielkości liczbowych w poprawny sposób (malejąco - rosnąco) przy kliknięciu w nagłówek kolumny ?
I jak to obejść ?

Już sobie grzecznie odpisuję - bo nie korzystam z LTR.


Załączone pliki Miniatury
   
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
12-12-2016, 09:34 PM
Post: #2
RE: niepoprawne sortowanie w tabeli atrybutów
Trudno powiedzieć co jest grany w Twoim systemie, zatem, bez kombinowania, odpal plugin MMQGIS => Modify => Sort.

Jeśli wtedy zamykasz Qgis, otwierasz ponownie i ładujesz nowo powstałą shape'a, jak wygląda sortowanie tabeli atrybutów?
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
12-12-2016, 11:10 PM (Ten post był ostatnio modyfikowany: 12-12-2016 11:11 PM przez Mazur.)
Post: #3
RE: niepoprawne sortowanie w tabeli atrybutów
(12-12-2016 09:34 PM)Italiano napisał(a):  Trudno powiedzieć co jest grany w Twoim systemie, zatem, bez kombinowania, odpal plugin MMQGIS => Modify => Sort.

Jeśli wtedy zamykasz Qgis, otwierasz ponownie i ładujesz nowo powstałą shape'a, jak wygląda sortowanie tabeli atrybutów?

Problemy z sortowaniem dotyczą tylko wektorów powstałych z wektoryzacji rastra. Wtedy MMQGIS nie działa ani w Nodebo ani we wcześniejszych wer. Wtedy też sortowanie kliknięciem w nagłówek tabeli argum. nie działa tylko w Nodebo a we wcześniejszych wer. działa.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
13-12-2016, 02:51 PM
Post: #4
RE: niepoprawne sortowanie w tabeli atrybutów
Zmień typ pola na liczbowy. Teraz najwyraźniej masz tekstowy, stąd takie sortowanie.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
13-12-2016, 03:24 PM
Post: #5
RE: niepoprawne sortowanie w tabeli atrybutów
(13-12-2016 02:51 PM)Binko napisał(a):  Zmień typ pola na liczbowy. Teraz najwyraźniej masz tekstowy, stąd takie sortowanie

W życiu! [Obrazek: smile.gif] Teraz jest liczbowy, gdyż justyfikacja jest po prawej stronie...
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Zawijanie tekstu w tabeli atrybutów wycinka 3 247 12-01-2018 02:04 PM
Ostatni post: Italiano
  Plik excel w tabeli atrybutów Kzyhó 8 5 287 15-07-2017 04:39 PM
Ostatni post: karol.stachura
  Jak przedstawić dane z tabeli atrybutów w postaci graficznej Pablitto 2 2 797 28-03-2017 10:10 PM
Ostatni post: Pablitto
  Tworzenie geometrii dla tabeli atrybutów bez geometrii tomalos 17 16 743 04-12-2016 12:38 AM
Ostatni post: borys
  Eksport z tabeli atrybutów do excel eamonn 6 21 606 10-10-2016 01:33 PM
Ostatni post: Binko
  cięcie linii wg atrybutów z innej tabeli sienek 0 4 503 18-06-2015 11:16 AM
Ostatni post: sienek
  zmiana kolejności i nazwy atrybutów w tabeli atrybutów phacops 2 6 521 11-12-2014 09:20 PM
Ostatni post: phacops
  Niepoprawne wymierzanie odległości na mapie wojzal2 3 6 315 26-10-2014 07:52 PM
Ostatni post: martel
  wycięcie fragmentu tekstu z kolumny w tabeli atrybutów kabanoska 1 4 958 03-10-2014 01:31 PM
Ostatni post: kabanoska
  Problem z łączeniem tabeli atrybutów dwóch warst skorasp 1 6 334 18-02-2014 12:29 AM
Ostatni post: borys

Skocz do: