Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 14.04.3 LTS
09-11-2015, 12:53 PM (Ten post był ostatnio modyfikowany: 09-11-2015 01:49 PM przez Saalomon.)
Post: #1
Ubuntu 14.04.3 LTS
Witam.
Postanowiłem przesiąść się na Linuksa, dokładnie na dystrybucję z tytułu i w związku z tym mam pewien problem (zaznaczę tu że jak na razie jestem całkowicie zielony, ale powoli dam rade!Smile). Niestety jak najszybciej potrzebuję aktualnej wersji Qgis, a domyślnym repozytorium jest wersja 2.0. Doczytałem już że muszę dodać nowe repozytorium, dodałem to ze strony qgis : "deb http://qgis.org/debian jessie main". Po uruchomieniu centrum oprogramowania ubuntu i próbie rozpoczęcia instalacji pojawia się okno: "Zależności pakietu nie mogą zostać rozwiązane". Gdy dodam repozytorium deb http://ppa.launchpad.net/ubuntugis/ubunt...ble/ubuntu trusty main , w cou pojawia się komunikat: "Wymaga instalacji niezaufanych pakietów", po kliknięciu OK x3 instalacja nie rozpoczyna się. Powiedźcie proszę co dalej? Może jest jakiś inny sposób?
Przepraszam wszystkich, których mój poziom umiejętności obsługi systemu obraża, ale każdy kiedyś zaczynał, a zależy mi na szybkiej instalacji aktualnego Qgis.
Pokornie proszę o wszelkie, jednak przedstawione możliwe najprościej rady.
Z góry bardzo bardzo dziękuję!Smile
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
09-11-2015, 09:34 PM
Post: #2
RE: Ubuntu 14.04.3 LTS
Ok - masz Ubuntu, a dodałeś repo dla Debiana Wink (jessie, to kodowa nazwa wersji Debiana. Nazwa kodowa Ubuntu 14.04 to trusty)

W /etc/apt/sources.list powinieneś mieć taki wpis:

Kod:
deb     http://qgis.org/debian trusty main
deb-src http://qgis.org/debian trusty main

Następnie w konsoli wpisz po kolei:
Kod:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key 3FF5FFCAD71472C4
sudo apt-get update
sudo apt-get install qgis python-qgis qgis-plugin-grass


WAŻNE! Upewnij się, że usunąłeś inne repozytoria (np. ppa launchpad). W zupełności wystarczy tylko powyższe.

Powodzenia!
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
09-11-2015, 11:09 PM
Post: #3
RE: Ubuntu 14.04.3 LTS
Próbowałem próbowałem i samemu udało mi się dojść co trzeba zmienić w nazwie repozytorium, ale bardzo dziękuję za zainteresowanie i odpowiedź. Niemniej korzystając z okazji, może uda mi się rozwiać inne wątpliwości.
Mianowicie użyłem tylko jednego repozytorium "deb ....", nie wpisywałem nic w konsole (repozytorium dodałem przez okno") a udało mi się zainstalować Qgis 2.12. Miałem kilka problemów z niezaufanymi pakietami, ale metodą prób i błędów udało się. Czy ten wpis w konsoli jest konieczny?
No i pytanie które pewnie wywoła salwę śmiechu, czy Qgis wygląda inaczej i ma inne funkcjonalności na windows i linkuks? Przed wersją 2.12 zainstalowałem 2.8, z tej samej korzystam na windows i wydało mi się że brakuje kilku opcji, np. na windows opcja dodawania map z google itp jest wbudowana, na linuks natomiast musiałem doinstalować wtyczkę. Generalnie na pierwszy rzut oka nie zauważyłem różnicy między Qgis 2.0 (z domyślnego repozytorium) i 2.12 (z tego z którym tak się męczyłemSad). Tak powinno być? Już się w tym wszystkim trochę gubię.
Z góry dziękuję za odpowiedź i cierpliwość.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
10-11-2015, 04:55 AM
Post: #4
RE: Ubuntu 14.04.3 LTS
Między wersjami (2.0 a 2.12) na pewno są różnice, zarówno w wyglądzie jak i funkcjonalności.

Tak poza tym, to wersja na Linuksa i Windowsa nie różni się od siebie zbytnio. Ot, specyfika systemu i środowiska graficznego. Ale na przykład właściwości projektu na Linuksie są w menu "Ustawienia", a na Windowsie w menu "Projekt". Ale poza tym, to oferują to samo i działają tak samo.


O jaki wpis w konsoli Ci chodzi? Jeśli o zaimportowanie klucza GPG, to jest on potrzebny, bo jeśli będziesz chciał sobie zaktualizować system, to brak klucza jednego z repozytoriów uniemożliwi to. Chyba, że teraz całkiem wywalisz repo QGISa, skoro masz już zainstalowane Wink


Ps. Nie spotkałem się z domyślnie włączoną wtyczką do obsługi map Google na Windowsie Sad
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
11-11-2015, 09:59 AM (Ten post był ostatnio modyfikowany: 11-11-2015 10:14 AM przez Saalomon.)
Post: #5
RE: Ubuntu 14.04.3 LTS
Z tymi mapami googla chodziło mi o to że we wcześniejszych wersjach musiałem doinstalować wtyczkę,a w wersji 2.8 mapy online były w zakładce "W internecie".
Nie mniej dzięki wielkie za pomocSmile A mam jeszcze pytanie dotyczące samego linuksa, bardzo różnią sie od siebie dystrybucje 12 i 14? Znalazłem w sieci jakiś podręcznik do 12.04 i zastanawiam się czy przez analogię mogę go zastosować w swoim przypadku?
Orientujesz się może jak doinstalować w Qgis na linuksie wtyczkę której nie ma w repozytorium programu? Chodzi mi dokładnie o wtyczkę CADInput.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
12-11-2015, 01:58 AM
Post: #6
RE: Ubuntu 14.04.3 LTS
14 jest moim zdaniem lepiej dopracowana, szybsza... chociaż i tak z Minta korzystam. Ale jeśli masz jakiś podręcznik, to użytkowanie jest takie samo, komendy w terminalu takie same, trudno mi niestety powiedzieć co dla początkującego będzie znaczną różnicą... Wink

Dodatkowe wtyczki spoza repozytorium można doinstalować rozpakowując je do ~/.qgis2/python/plugins/ (czyli do katalogi .qgis2, który znajduje się w Twoim katalogu domowym. Jest ukryty, bo ma kropkę na początku nazwy (CTRL+H pokazuje/ukrywa ukryte foldery // LewyALT+. w KDE))
Tam siedzą praktycznie wszystkie zainstalowane wtyczki.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
13-11-2015, 11:52 AM
Post: #7
RE: Ubuntu 14.04.3 LTS
Dzięki wielkie za pomoc! Dzięki Tobie o wiele przyśpieszyłem swoją praceSmile
Zapytam jeszcze tylko o wtyczki instalowane spoza Qgis. Są jakieś specjalne wersje pod LInuksa, czy te które ściągałem na windows będą działały?
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
15-11-2015, 11:21 PM
Post: #8
RE: Ubuntu 14.04.3 LTS
Wtyczka jest wtyczką - to jest Python, więc platforma nie ma znaczenia Wink
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
16-11-2015, 06:57 PM
Post: #9
RE: Ubuntu 14.04.3 LTS
Stokrotne dzięki!Smile Wszystko działa w jak najlepszym porządkuSmile W razie jakiś kłopotów mogę liczyć na dalszą pomoc?Wink
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
16-11-2015, 09:51 PM
Post: #10
RE: Ubuntu 14.04.3 LTS
Jasne, jak tylko będę umiał pomóc - pomogę Smile
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Ubuntu 9.10 i PostgreSQL / PostGIS tomalos 2 27 427 20-04-2010 08:18 AM
Ostatni post: tomalos

Skocz do: